注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

^_^ china.ygw的博客

软件开发/c/c++/数据库/开源/linux/windows/安全/网络...

 
 
 

日志

 
 
 
 

使用git出现的“'receive.denyCurrentBranch' Configuration variable to 'refuse'”问题及解决  

2013-08-07 23:56:07|  分类: git |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

        前两癸因为工作需要,安装了git软件。其中服务端安装在linux下,并使用git  init来初始化仓库。但是问题随之而来,在客户端使用clone命令时总是失败,错误提示信息一大堆,比较注意的是“'receive.denyCurrentBranch' Configuration variable to 'refuse'”提示。
        后来与同事交流,才知道初始化仓库指令时有问题,正确的应该是git  --bare  init  --shared
        有问题的命令只适用于个人使用,但是涉及多人操作,还是要使用后面的命令。
        把已经建立的仓库删除后使用新的命令重新建立仓库,再使用时一切OK.
  评论这张
 
阅读(2501)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018