注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

^_^ china.ygw的博客

软件开发/c/c++/数据库/开源/linux/windows/安全/网络...

 
 
 

日志

 
 
 
 

linux下源代码方式编译php出现的“ZTS currently requires working posix threads...”问题及解决  

2013-08-15 22:22:40|  分类: linux |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
        今天,因为一些原因,需要在linux系统下把正在使用的5.4.0版本php换成5.3.3版本,在使用成功编译5.4版本php命令编译5.3.3版本php时,问题出来了。在configure时就报错,错误提示信息如下:
        error: ZTS currently requires working posix threads. we were unable to verify that your system supports Pthreds.
        很奇怪,我在linux环境下编译了很多次的php源代码,各个版本都有涉及,但是这个问题还是首次遇到。
        与同事沟通,也是不清楚。从报错的提示来看,感觉是系统不支持posix threads,但是这个是不可能的。只有怀疑是5.3.3版本php与5.4.0版本php有太多区别。
        后来在网上google了很久,才发现一篇文章。说是把源代码根目录下configure文件中的pthreads_working=no全部改成pthreads_working=yes。
        改完再次编译,问题解决,赶快记录下来^_^
  评论这张
 
阅读(444)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018