注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

^_^ china.ygw的博客

软件开发/c/c++/数据库/开源/linux/windows/安全/网络...

 
 
 

日志

 
 
 
 

XCode的“NSInternalInconsistencyException”内部错误问题解决  

2011-08-01 22:02:27|  分类: Mac OS |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

       这段时间,小整了一下Mac OS系统,不过遗憾的是我机器的CPU不支持虚拟化技术,导致虚拟机安装Mac OS后运行非常慢,即使我给它分配了4个处理器,4G内存。其安装的就“10.6.3东皇v2.2繁简英整合版”,XCode为3.2.3版本,IPhone SDK为4.0版本。

       对于软件,我个人还是比较喜欢新版本,不管是从功能上,还是从已知问题的解决方面来看,新版本大部分情况下总是会比老版本好,所以,只要软件有新版本,我还是会尽早更新。

       通过系统自已的更新功能将Mac OS升级为10.6.8,然后从苹果网站上下载并安装了最新的4.0.3版本XCode与4.3版本的IPhone SDK。不过郁闷的事情开始了,启动XCodej时报错:

        UNCAUGHT EXCEPTION (NSInternalInconsistencyException): Couldn't load plug-in 'com.apple.dt.IDE.IDEiPhoneSupport' while firing fault for extension 'Xcode.Device.iPhone'

         UserInfo: {
NSUnderlyingError = "Error Domain=DVTPlugInErrorDomain Code=2 UserInfo= ......

        如下图:       

XCode的“NSInternalInconsistencyException”内部错误问题解决 - china.ygw - ^_^ china.ygw的博客

       经过查找,原来是ITunes安装缺少一个关键组+导致,解决步骤如下:

      1)关闭系统中正在运行的ITunes软件;

      2)使用活动监视器(Activity Monitor,位于“Finder”--->“应用程序”--->“实用工具中”中)终止正在后台运行的ITunesHelper进程;(注意,这步是关键

      3)从苹果网站下载最新的ITunes软件;

      4)安装已经下载完的ITunes软件;

      按照以上步骤完成操作后,再次启动XCode,问题解决,又去了一块心病^_^

  评论这张
 
阅读(3290)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018